Post Top Ad

Your Ad Spot

sábado, 12 de septiembre de 2020

"El argumento de clase no es válido:" problema en Magento 2.3.3 en Admin Grid

En la nueva versión de Magento 2.3.3, tenemos un nuevo problema al abrir algunas cuadrículas de administración. Este problema proviene de las acciones masivas que tienen subopciones. Encontrará una excepción como " El argumento de clase no es válido: Webkul \ ModuleName \ Ui \ Component \ MassAction \ StatusOptions " como se muestra a continuación,
Exception
En versiones anteriores de Magento, es decir, versiones anteriores a Magento 2.3.3 en el archivo XML del componente de interfaz de usuario, usamos la siguiente sintaxis para crear acciones masivas con subopciones,
Así que ahora veamos qué cambios necesitamos hacer para que funcione. En lugar del código anterior, tendremos que escribir el código siguiente en el archivo XML del componente de la interfaz de usuario,
Ahora necesitamos agregar algunas líneas más en el archivo etc / di.xml como se muestra a continuación,
Ahora ejecute el comando di compile y debería funcionar como se esperaba.
Gracias por leer el blog. No dude en comentar si tiene algún problema.


Feliz codificación 👨 💻

No hay comentarios.:

Publicar un comentario

Dejanos tu comentario para seguir mejorando!

outbrain

Páginas