Header Ads Widget

Ticker

6/recent/ticker-posts

Instalación de Magento2.4

Hola, Magento 2.4 se lanzó el 28 de julio de 2020. Puedes leer las notas de la versión desde aquí . Mientras instalaba Magento 2.4 enfrenté algunos problemas aquí, voy a explicar eso. La mayoría de la gente instala Magento usando la interfaz de usuario web, pero ahora en Magento 2.4, solo puede instalarlo a través de CLI. Puede consultar los requisitos de su servidor desde aquí . Se recomienda instalar Magento 2.4 en PHP 7.4 incluso se puede instalar en 7.3 pero no se recomienda, también apache 2.4 que es igual a la versión anterior, y ahora tienes que actualizar tu versión de MySQL a la última MySQL 8.

Nota:

Pero incluso después de actualizar arriba y todas las extensiones requeridas por PHP, necesita configurar e instalar la búsqueda elástica 7.6.x en su sistema, o cualquier otro servidor para instalar Magento 2.4 porque la búsqueda elástica es ahora el motor de búsqueda predeterminado para la interfaz de Magento, así que ahora no puede instalar Magento sin la búsqueda elástica.
Veamos paso a paso cómo instalar Magento 2.4 desde CLI:
Otra cosa a tener en cuenta Magento 2.4 no se puede instalar en Windows o Mac, ahora solo es compatible con distribuciones de Linux como CentOS, Ubuntu, Debian y similares.
Otro problema al que se enfrentará, una vez realizada la instalación, no podrá iniciar sesión en el panel de administración de Magento porque en Magento2.4 está instalada la autenticación de dos factores y no le permitirá iniciar sesión hasta que proporcione el correo electrónico correcto y configure SMTP para que Magento pueda enviar un correo electrónico, en ese caso, la única solución que encontré es desactivar el módulo de autenticación de dos factores:

Publicar un comentario

0 Comentarios