Header Ads Widget

Ticker

6/recent/ticker-posts

Cómo Instalar Y Configurar Codeigniter En XAMPP

 Este tutorial ayuda a configurar e instalar Codeigniter 4. Esta es la última versión de codeigniter y es compatible con php 7.2+ . CodeIgniter 3.1.11 es la versión estable del marco compatible con PHP 5.6+.

CodeIgniter 4 es la próxima versión del marco, diseñada para su uso con PHP7.2. El desarrollo está en marcha y la versión actual es v4.0.0-rc.3. Puede obtener más información aquí .

CodeIgniter es un potente marco PHP con una huella muy pequeña, creado para desarrolladores que necesitan un conjunto de herramientas simple y elegante para crear aplicaciones web con todas las funciones.

El Requisito Previo Para Codeigniter 4

  • El sistema debe tener php 7.2+.
  • El compositor debe haberse instalado en el sistema.
  • El paquete php internationalize ( php_intl.dll ) debe estar habilitado.

Estoy usando xampp para instalar y configurar codeigniter.Puede verificar la versión de php usando el siguiente comando:

Instalar CodeIgniter En Xampp

Estoy usando composer para instalar el paquete. Abra la ventana de comandos de la ventana y ejecute el siguiente comando:

composer create-project codeigniter4/appstarter codeigniter-blog -s rc

codeigniter-blog es el nombre de su proyecto codeigniter.

Estoy creando una aplicación esqueleto de codeigniter 4, el repositorio de inicio de la aplicación CodeIgniter 4 contiene una aplicación esqueleto, con una dependencia del compositor en la última versión lanzada del marco.

Ahora, actualizaremos la dependencia usando el siguiente comando. Siempre que haya una nueva versión, desde la línea de comando en la raíz de su proyecto:

composer update

Crear Host Virtual En XAMPP

Creemos un host virtual para estos proyectos de codeigniter, abra el httpd-vhosts.confarchivo Apache que se encuentra en D:\xampp\apache\conf\extra\httpd-vhosts.conf, Agregado debajo de las líneas de código al final del archivo.

Ahora, abra el archivo de hosts que se encuentra en C:\Windows\System32\drivers\etc\hosts, Se agregó el siguiente código en este archivo al final.
127.0.0.1 codeigniter-blog.com

reinicie el servidor xampp.

Abramos el navegador y naveguemos http://codeigniter-blog.com, si está recibiendo la página de bienvenida, eso significa que todo está bien, de lo contrario, el intlpaquete no está habilitado.

Puede habilitar el paquete php intl siguiendo los pasos:

El Archivo Php_intl.Dll Existe En La Carpeta Php / Ext

  • Abra el archivo de configuración php ( php.ini ) generalmente en la misma carpeta que el ejecutable php.
  • Busque la "extension=php_intl.dll"línea en el php.iniarchivo, si existe y está comentada, elimine los comentarios.
  • Reinicie el servidor web (generalmente Apache).
  • Verifique si la extensión está habilitada usando phpinfo () .

Php_intl.Dll No Existe En La Carpeta Php / Ext

  • Verifique su versión de php ejecutando el php -vcomando.
  • Descargue la versión de PHP que corresponda a la suya desde la página de descargas de PHP (TS / NTS, x86 / x64).
  • Busque el archivo php_intl.dll en la carpeta ext en esa versión y cópielo en su php\extcarpeta.
  • Busque el php.iniarchivo y ábralo.
  • Agregue "extension=php_intl.dll"en el php.iniarchivo.
  • Reinicie el servidor web (generalmente apache)
  • Verifique si la extensión está habilitada usando phpinfo ()

Abra su navegador favorito y navegue http://codeigniter-blog.comCon suerte, recibirá un mensaje de bienvenida de codeigniter.

Publicar un comentario

0 Comentarios