Header Ads Widget

Ticker

6/recent/ticker-posts

CentOS: Cómo corregir el error: Versiones protegidas de multilib: package.i686! = Package.x86_64

 Error de ejemplo:

1
Protected multilib versions: audit-libs-2.8.5-4.el7.i686 != audit-libs-2.8.4-4.el7.x86_64

Check in yum

1
yum list|grep -i audit-libs

Verá una versión antigua x86_64 instalada y 2 versiones nuevas (una x86_64 y una i686) disponibles en yum como:

1
2
3
4
5
6
7
8
9
[root@tutorialspots ~]# yum list|grep -i audit-libs
audit-libs.x86_64                        2.8.4-4.el7                  @base
audit-libs.x86_64                        2.8.5-4.el7                  installed
audit-libs-python.x86_64                 2.8.5-4.el7                  @base
audit-libs.i686                          2.8.5-4.el7                  base
audit-libs-devel.i686                    2.8.5-4.el7                  base
audit-libs-devel.x86_64                  2.8.5-4.el7                  base
audit-libs-static.i686                   2.8.5-4.el7                  base
audit-libs-static.x86_64                 2.8.5-4.el7                  base

Reparar:

Método 1: eliminar la versión anterior

1
yum remove -y audit-libs.x86_64

o eliminar solo este paquete (sin eliminar dependencias)

1
rpm -e --nodeps audit-libs-2.8.4-4.el7.x86_64

Método 2: actualiza yum

1
yum update

Publicar un comentario

0 Comentarios